CrossBox 2019


#41

Yeah, and sometimes it’s involuntary :smile:

I just thought they were related with the slowness on the first time log in.

It’s a good product, congrats.


#42

Love CrossBox! :grin: Excellent work. I havent tested the new update yet.


#43

I received two notifications in Chrome saying something like:

  • “This site was updated in the background”
  • “{Something} mybox@mydomain.com”. Where {something} is something I couldn’t read because it disappeared fast, but it’s about new messages.

Weird thing is I’m not logged in at all in mail.mxroute.com or cPanel.


#44

Did you really log out or you just closed the tab? Or is it possible that you had multiple accounts logged in and then you didn’t log out from each of them? Either way, thanks for the report and we’re trying right now to reproduce it on the test servers.

Yes, this was a bug that happened sometimes where the notification’s message was replaced by the browser, but it’s fixed in v0.3.7.


#45

Actually I don’t remember. I haven’t logged in for 3 or 4 days and session should be already closed. When I entered to mail.mxroute.com to see what happened, it asked me for credentials.


#46

I think @imok’s case is so because mail.mxroute.com is still in v0.3.6 beta?


#47

I have never been able to use CrossBox at MXroute
Anyone knows why this error happens?


#48

The actual master’s URL is [REDACTED] but you’re right, the MXroute is still on v0.3.6. beta


#49

It could be one of three things:

  • CrossBox was never installed on eagle
  • It was stopped with CLI command “crossbox stop”
  • The firewall on eagle is blocking 1703 port

#50

It was installed on Eagle, but had to be disabled due to memory issues (my recollection, anyway). It not working on Eagle is a known issue, in any event.


#51

We’ve received one report that this happened a while back (on one of the MXroute’s servers) because of one user having an email thread consisting of 100k or 200k messages (I don’t remember an exact number). It was fixed the same day and pushed via an emergency push channel. We solved it by chopping down those huge threads into X threads with 100 messages each.

Even though this was a rare case with a low occurrence count (1-2 people out of thousands), there is no excuse not to make sure that the threading algorithm works smoothly no matter how simple or complex the user’s mailbox is.

This issue was on the Banshee server and not on Eagle.


#52

@Jarland Any plans to install this update on MXRoute?

What. TIL some people have single threads with more emails than my entire inbox with 10+ years worth of email in it.


#53

Ah, ok then. The hazards of answering when @Jarland should be. :joy:

I guess that issue was encountered before the Eagle install, and then Jar just put it off and hasn’t gotten back to it.


#54

I’m sure. I’m drowned by my to-do list :frowning:


#55

Just imagine someone having a cron job email arrive every 15 minutes for a year :smile:

We don’t create more work for providers (like the stuff they already do is not enough) by constantly requiring them to update. There is an update push system with which we can decide what servers get the update. This gives us great flexibility in rolling out the updates across a range of different providers. First, the update is tested on our test cluster and then continues up from standalone installations to smaller clusters and at the end to the larger ones. This way we can spot a potential bug earlier and prevent it from affecting a larger number of users. We can also push hotfix patches by forcing server (s) to apply it immediately. This is useful in the event of a security-related or other critical level issues that need to be addressed immediately.


#56

MXRoute is finally on v0.3.7 RC-1 but the Branding feature is turned off (getting a “Nothing here…” message). A couple of things:

  1. @CrossBox, perhaps it’ll be more intuitive if the Admin link is removed altogether if that feature is not allowed; and
  2. @Jarland, will it ever be available in MXRoute? :blush:

EDIT: see @Daniel’s comment below :arrow_double_down:


#57

If there’s a feature I need to turn on I surely will.


#58

I think it’s this?


#59

This took me a long time to figure out. The UX isn’t ideal at the moment, it should really have a better null state. You need to click the “+” button at the bottom right :slight_smile:

Works great once you do that! An example: https://mail.alisonanddaniel.com/. Works for SMTP and IMAP too. No need for any extra config at your end @Jarland!

@CrossBox - A few requests from me:

  1. The “settings” menu items are totally broken in Firefox in the latest update :frowning:
  2. The branding feature caches negative DNS responses for way too long. I tried using mail.alisonanddan.com and got "mail.alisonanddan.com hosts do not have CNAME or A records for: mail.example.com or 198.51.100.1" (just example values). I added the CNAME and tried again, but it didn’t work. Thought it was an issue with a CNAME so changed it to an ALIAS. Tried 10 minutes later, it still didn’t work. I think it should not cache negative responses at all.
  3. Add a better landing page for branding feature, as right now it’s not obvious how to add new branding
  4. For cPanel-integrated accounts, treat _mainaccount@example.com as an admin in addition to admin@example.com - _mainaccount represents the default cPanel account for the domain
  5. Make the “app description” optional? Seems silly to require it

#60

Oh wow, you’re right! Thanks!

And I do agree, it should have at least a note saying something like “Please create a new Branding instance by clicking on the Add button below” when no current Branding instance is available.

Sorry for bothering you @Jarland!