CrossBox 2019


#61

Looks like the whitelisted MXroute domain (mail.domain.com) is currently unavailable.


#62

Good to see you guys figured it out! Sometimes that FAB button is not so visible it seems.

  1. The FireFox issue is indeed reproducible and the patch that fixes this will be on its way soon.

  2. Regarding the DNS cache, that’s correct and currently, you either need to add a CNAME/A record first and then create a branding profile or wait until the server refreshes the DNS cache. We’ll work on a solution for this and we’ll push it in the next update.

  3. We’ll update that message to indicate that you currently don’t have any branding profiles and that you can proceed to create one.

  4. This is possible, I’ll talk to the devs.

  5. We can make it optional, thanks.

We appreciate the feedback!


#63

Gotta love the CrossBox guys, seriously.


#64

Thanks!

Today my branding config says “this config is disabled” and hitting the domain says “That host is not allowed”… Why would it get disabled? How could I re-enable it?


#65

Keeps getting better and better :slight_smile:


#66

@Daniel

Some branding profiles got temporarily disabled because of the safety check. CrossBox periodically queries the DNS records of the mounted domain to confirm that it resolves to the server and disables the access to the mounted domain if the check is not passed. The problem was that the server sometimes didn’t return DNS records at all. This is now fixed and from now on the checks are done via 8.8.8.8, 8.8.4.4, 1.1.1.1 and are tolerant to multiple fails until enough time passes and more checks confirm that the mounted domain no longer resolves to the server, for real.

Your profile should be automatically re-enabled after the server you’re on receives the patch.


#67

Hi @CrossBox, I don’t think it was mentioned already, but I got stuck at the below prompt when setting up an account (on MXRoute’s):

image

There’s no way to go to the Next Step if we don’t allow the notification permission. I think we should be able to proceed without allowing the notification :slightly_smiling_face:

Some users will have notifications disabled by default, or click Deny automatically and be stuck there without knowing what to do.


#68

Hey @sshd !

Allowing notifications is not mandatory. You can just click “Next” and it should let you go to the next step.


#69

I’ve tried again with another account, and this time it worked… Might have been a glitch from my browser! My bad :sweat_smile:


#70

Crossbox support still top notch. I’m over here with multiple accounts confusing the hell out of my self :smiley: