CrossBox 2019


#21

Sadly, Crossbox is totally inusable on MXRoute.
The UI looks nice, but the loading times are garbage.

5 Seconds to get into the inbox, another 5 seconds for every other email.
I prefer roundcube over it, works better and faster.


#22

Sorry to hear that but you can’t really compare those two as roundcube reads from mysql and crossbox from imap.

The speed you get with CrossBox depends on the speed of IMAP server, so this may be an isolated case.


#23

Of course you can compare them.

The only thing I need, is a good email software, to read my emails.
Which is not the case if it takes everytime 5 seconds.

That makes it pretty inusable.

I would not blame the IAMP, since roundcube is a lot faster, fetching all my latest emails compared to your software. I would rather say your software is poorly coded.


#24

You are ignoring the fact that RoundCube reads emails from MySQL which is a lot different than reading from IMAP. Basically, any email client (Thunderbird, Outlook, Mailbird) you connect will also have a 5 second delay if that’s the case.

We have thousands of active users and we wouldn’t have if what you’re saying was generally regarded as the truth.

Maybe you can tell us on what server you are hosted so we can check it with MXroute and next time avoid stating something that is not correct before checking out what the issue really is.


#25

I tested it on 2 different mx servers, same result.
Enough for me, to stay with roundcube.

As I said the UI is nice, but the performance is to slow to be usable for me.


#26

I experienced this on large mailboxes but honestly haven’t tested it again. I’m so very far behind on my to-do list right now.


#27

I understand your point but you should have contacted us first and work with us to have it resolved (which we always execute promptly) instead of jumping to wrong conclusion and painting to people a wrong picture about the software.


#28

Is the version displayed to end-users in the UI anywhere? I can’t see it anywhere on my MXRoute account, so I’m just watching the VERSION field in the config file (/dist/config.js) to see if the server has gotten the 0.3.7 update :stuck_out_tongue:


#29

Hehehe, that’s a good catch :sunglasses:

For those looking for an easier way than Daniel’s, the version is displayed at the login screen in bottom right corner.


#30

Ahh, I was already logged in to my account, so I didn’t see that. Thanks!


#31

If you have CrossBox open when the update arrives, a dialog will appear prompting you to decide if you want to update and load the new version immediately or if you’d rather update at a more convenient time of your choosing. :face_with_monocle:


#32

I’ve just seen CrossBox is available in MXRoute. Tried with a new mailbox and it took more than a minute to log in.

It looks like you are upset about CrossBox. Why?
Load time could be a temporary issue.


#33

If it’s your first log in then you have to wait until database for your CrossBox is created under your cPanel account. This is only a one time process and depends on the speed of the MySQL server :yum:


#34

If that’s the case, a message in the screen saying what’s happening would be great.


#35

That’s a good point. First impressions are key. And if the first time the user accesses the mailbox they are waiting over a minute just to sign in, then they would understandingly view the software as slow. A simple “We are creating your CrossBox mailbox, please stand by” or something similar would be hugely beneficial.


#36

There is already such a feature (I’ve blured the branded logo):

Maybe a message should be more informative?


#37

That’s more than sufficient. Based on @imok’s comment, I didn’t think this was a feature.

@imok - did you not see this message when you first logged in?


#38

Maybe he was using the autologin feature from cPanel which does not show this message (it’s fixed in 0.3.7).


#39

That should be enough.

Maybe he was using the autologin feature from cPanel which does not show this message (it’s fixed in 0.3.7).

I entered from the screen that shows more options: Crossbox, Horde, Roundcube. And I didn’t see any message but a lot of errors on console. I don’t now what version @Jarland is running on MXRoute.

EDIT: Tried again with another new mailbox and it was fast (less than 5 seconds). But still no message.

These are the errors but it looks like they don’t have any impact.


Doubt: the logged-in notifications are tracked only when you sign in to Crossbox or the entire cPanel Webmail system (Horde and the other stuff)?

Also, when I enable Dark Mode, it reverts to Light after some seconds:

The previous checkbox should override image at least for the current session.


#40

It’s 0.3.6 beta at MXroute. The errors you see in the console are irrelevant and the end-users usually don’t go poking around the console, but for some guys like you and me, it’s a standard procedure.

Good question. Answer: only when CrossBox login has been made.

Currently, it’s the other way around. You first disable the
image
and then the quick switching works without the automatic setting interfering.

All ideas are welcome and thank you @imok for taking the time to check out CrossBox!