Windows - Kimsufi - QEMU - Fresh Install - (probably will work for others too)

Hello, I could not find any “templates” for Windows Server 2019, so decided to try setting up the same on Kimsufi via QEMU… Also, the fact that it is always good to do a fresh clean install so you can be sure it is as per your specifications. I will try to update this with screenshots when time permits. I have got this working from scouring the internet for multiple solutions and finally was able to complete it successfully.

Steps are for Kimsufi only, it may work for other providers too…

  • Boot your server to the “rescue” mode and login with the new credentials received from Kimsufi
  • Download QEMU in temp folder

wget -qO- /tmp | tar xvz -C /tmp

  • Download official Windows Server 2019 ISO from Microsoft. This could take a long time depending on your connection

cd /tmp


  • You will need to download and keep ready VNC Viewer as you will need to boot from this ISO.
  • Open VNC Viewer and keep connection to following IPADDRESS:5901 ready
  • Run the QEMU with the newly downloaded ISO.

/tmp/qemu-system-x86_64 -net nic -net user,hostfwd=tcp::3389-:3389 -m 10000M -localtime -enable-kvm -cpu core2duo,+nx -smp 2 -usbdevice tablet -k en-us -cdrom /tmp/17763.379.190312-0539.rs5_release_svc_refresh_SERVER_EVAL_x64FRE_en-us.iso -hda /dev/sda -vnc :1 -boot d

  • Press any key to boot from the CD/ DVD (as displayed on the screen.
  • If you miss the boot selection, you can go back to the rescue system and hit and run the above command again and try to get to the boot selection from DVD.
  • Select any option from the OS selection with “Desktop Experience”.
  • Complete the installation. Warning: This will delete all your information on the server and install a fresh instance of Windows Server 2019 Standard.
  • It will probably restart on its own during the installation. This time, you need not select the boot from CD/DVD.
  • If all goes well, you will be prompted for setting the Administrator password. Choose one wisely and you will login
  • On the Server Manager (that opens up by default). Select “Local Server” from left menu (below Dashboard). Find the option “IE Enhanced Security Configuration” and turn it off temporarily. Else, you will get annoying popups when trying to open a web page
  • Go to the Windows Defender Firewall with Advanced Security → Inbound rules → Enable “File and Printer Sharing (Echo Request - ICMPv4-In)” rule. This will allow us to ping the server and see when it comes online
  • Open cmd prompt and disable driver signing and integrity checks

bcdedit /set TESTSIGNING ON

  • **REBOOT ** your system NOW
  • After reboot, Download/ install any browser you want. if you are bold, you will continue using the IE installed by default
  • Download/ install 7zip/ any other utility which you can use to unzip files. I prefer 7Zip
  • Download and install the network drivers. In my case, I needed Intel 82579V Gigabit Ethernet drivers. However, support for these was removed in recent versions (after 23.5) from Intel.

  • So, we need to download an old, but official copy. Here is a direct link:

  • Original page of the drivers:
  • Select version 23.4 or earlier and download if the above link is moved
  • Go to the folder where you downloaded the driver package from Intel. Right click on that and extract it.
  • Go to \PRO1000\Winx64\NDIS65
  • Backup and create a copy of e1c65x64.inf file
  • Open the e1c65x64.inf file in notepad
  • Comment all lines by adding “;” under [ControlFlags]
  • You need to copy last 4 lines from [Intel.NTamd64.10.0.1] section and paste them in the section [Intel.NTamd64.10.0] towards the end

Please refer to the link at the end to see more about this. I did not get a chance to add screens for this.

  • Save the file
  • Open cmd
  • Go to the folder where you kept this new modified driver file. Run the following:

pnputil -i -a e1c65x64.inf

  • This should put a new prompt to “Agree” to the warning about installation of unsigned drivers
  • If you do not see this popup, you have missed the earlier step to disable driveer signing / rebooting your server. I have tried this multiple times, and it just works if followed correctly
  • Go to Settings → System → Remote Desktop and check on “Enable Remote Desktop”
  • Reboot your server

Thats it. On your local, ping your kimsufi server.
It should take a couple of minutes before the drivers are installed and server is up and running.

  • Consider restoring the driver signing options with bcdedit. I did not as I have COURAGE

I followed the blog at

PS: This is my first tutorial, this has worked for me. Hopefully it works for you as well.


Awesome wiki/tut post!! Thanks for sharing!

If anyone tries this out, please share your results and feedback :slight_smile:


one needs COURAGE for the desktop experience… I have it… do you?

Dude thank you so much, this was the best guide. I have had enough of using templates and dodgy copies :slight_smile: such a legend.

1 Like

I’ve been trying to install Arch on my damn Kimsufi for months. Thank you!
I’d gladly buy you an ice cream!
Edit: Just realized this thread is 2 years old :man_facepalming:

1 Like

So can someone confirm if you are able to go back into HDD and restart the server, each time I do this it never loads and the process is dead.

Is it supposed to stay in recovery mode forever?

Having the same issue, it reboots into rescue mode. :man_shrugging:
Guess we may be out of luck. Sacrificing my KS-7 to try on another machine

Also I’m installing Arch. Not Windows

Got everything working apart from the final step where it won’t ping and boot on HDD, trying to install windows as per this exact guide or the 2022 evaluation but so far neither work.

Maybe I should try the 2016 version as this guide uses 2019.

Not tried since the last time I wrote this. Sure please give 2k16 a try and post!

No dice. After install if you keep the rescue system booted you can use your installed OS, but the IP address is a bridge network, so VNC is the only way to connect to the Host OS. Ping works to connect outside, but no way to connect from a remote location (ssh, web browser, etc.).
After reboot the server fails to boot into the OS, and reboots into the rescue system.

Same for me, managed everything else except booting from HDD, on OVH it says “chain on hard drive failed”. Anyone has a solution?

Sherlock, did you just create an account to doxx someone? Why dont you share something and contribute to the community first and then judge?

If you are incapable to even understand the basics, you probably shouldn’t even manage or use a dedicated server. Its common sense…

Who doxxed someone? I’m missing some context.

1 Like

Oops. Sorry had something else in mind. Not doxxed.

Thrashing the OP (in this case me) for posting a great guide but still @Mshie feels entitled as it did not include info on rebooting thensystem.


Hey, thank you so much for making this guide! I managed to create the QEMU VM and followed the guide to a T without skipping a single letter. However, after I reboot the server after the last step, I am taken to Ubuntu, which is the OS on the main drive.

To me, this makes sense given that we are installing the VM in the Rescue partition, and not /dev/sda.

Maybe I’m missing something? Any ideas would be greatly appreciated. Thanks.

I am taking it upon myself to switch the boot mode back to “Boot from Disk” after setting everything up but now I wonder if that’s what I should be doing. Is this meant for running windows inside of qemu or natively? Are we supposed to switch back to booting if disk at any point?

If all is setup correctly it should run windows natively.
After reboot if you see ubuntu, its quite possible you installed it on the wrong disk?

Yes at all times, the last step will be to come out of rescue and boot normally and the server should be available to RDP connections

Hope this helps

1 Like

Hi there! I just made an account to thank you. Following this tutorial it worked like a charm in October 2023. :+1:

Fully functional Windows Server up and running! :clap: :clap:

Thanks a lot!