Proxmox Web Admin Issue

I have just changed broadband providers at home, although I am not sure this is related and I now have an issue accessing my proxmox gui admin console.

I can access the webgui from two different locations, but from home I am unable to connect and get

This site can’t be reached The connection was reset.

Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics

I am running iptables as a firewall on the host, but the rules look good, I have also tried with no firewall rules and get the same error. Firewalling is disabled on the host and datacentre from within proxmox. I don’t really know where else to look.

I am using Proxmox Virtual Environment 6.3-3 on Debian GNU/Linux 10 (buster) and both are up to date, I rebooted the server this morning to check if something weird was happening.

Just done a little bit more digging. In the pveproxy access log I see a - 403 error when the IP having issues tries to connect. All the other connections are passing information correctly. I am not sure what this actual means though

PVEProxy Log - [email protected] [28/01/2021:11:22:52 +0000] "GET /api2/json/nodes/xxx/status HTTP/1.1" 200 788 - [email protected] [28/01/2021:11:22:52 +0000] "GET /api2/json/cluster/tasks HTTP/1.1" 200 990 - [email protected] [28/01/2021:11:22:52 +0000] "GET /api2/json/nodes/xxx/firewall/options HTTP/1.1" 200 86 - [email protected] [28/01/2021:11:22:52 +0000] "GET /api2/json/cluster/resources HTTP/1.1" 200 678 - [email protected] [28/01/2021:11:22:53 +0000] "GET /api2/json/nodes/xxx/config HTTP/1.1" 200 62 - [email protected] [28/01/2021:11:22:53 +0000] "GET /api2/json/cluster/acme/account HTTP/1.1" 200 11 - - [28/01/2021:11:22:53 +0000] "-" 403 - - - [28/01/2021:11:22:53 +0000] "-" 403 - - - [28/01/2021:11:22:53 +0000] "-" 403 - - - [28/01/2021:11:22:53 +0000] "-" 403 -
And from syslog (fairly confident this is something else though)

Jan 28 11:25:24 xxx pveproxy[17070]: cannot parse line 'acme: ' in node config
Jan 28 11:25:34 xxx pveproxy[17174]: cannot parse line 'acme: ' in node config
Jan 28 11:25:44 xxx pveproxy[17174]: cannot parse line 'acme: ' in node config

Which suggests it might be an SSL error, but the cert is good and I forced a lets encrypt renewal this morning.

Ballers you’re my only hope :slight_smile:

Guess who forgot they configured an allow / deny list in did you /etc/default/pveproxy?