Issue with mounting external hard drive (Ubuntu 20.04 LTS)

Hey there, everyone.
I currently have an issue with an external hard disk not mounting automatically upon boot causing my Plex homeserver (Ubuntu 20.04 LTS; Futro S740; with desktop environment for rdp and other reasons) to not find the external drive with the plex media and thus resulting in me not being able to play movies from my plex without manually re-mounting the plex drive and re-starting the plexserver. The mount-issue is probably related to me (ympker) not being the “owner” of the mounted drive.

I have tried running

sudo chown ympker:ympker /mnt/8EDE4C27DE4C09C3/

but it still shows that I am not the owner of the drive.

I have created a bash script ( to perform the required tasks everytime this occurs, but it’s been tedious to always have to run this:

mount /dev/sdb1 /mnt/8EDE4C27DE4C09C3
chown -R ympker:ympker /mnt/8EDE4C27DE4C09C3
service plexmediaserver restart

I also setup a crontab to run the script, but it probably fails due to the same reasons mentioned above:

FSTAB looks like this:

/etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=a285f68e-0105-4cf2-8c69-1fd81382e593 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=AE12-7D53  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0
#external plex drive
UUID=8EDE4C27DE4C09C3 /mnt/8EDE4C27DE4C09C3 auto nosuid,nodev,nofail,x-gvfs-show 0 0

Any ideas how to fix the issue?

You’ll want to remove the mount and chown commands from that script, they’re unnecessary since you’re using your fstab.

Try changing your fstab’s last line to the following (switch out the uid and gid to match your user and group, which you can find out by running id ympker)

UUID=8EDE4C27DE4C09C3 /mnt/8EDE4C27DE4C09C3 auto nosuid,nodev,nofail,x-gvfs-show,uid=1000,gid=1000,umask=022 0 1

This worked beautifully after rebooting!
Thanks mate :slight_smile:

I assume it should work from now on. I’ll monitor it for a bit, but I don’t see why it wouldn’t work now :wink:

1 Like

Glad to hear it! You should be good :smiley:

1 Like

Any idea why me running sudo chown ympker:ympker /mnt/8EDE4C27DE4C09C3/ didn’t do the trick, initially? I mean, shouldn’t this command do exactly that, too?

I think that chowning doesn’t work at that level due to the permissions set by fstab; even if it did, those permissions wouldn’t persist due to the permissions set by fstab


Ah, right. That makes sense. Thanks! :slight_smile:
Enjoying Plex so far. Slowly building my library, that is :stuck_out_tongue:

1 Like

Nice! I’ve been managing my Plex library for…8 years now I think? Drop me a message if you run into anything unexpected :smiley:

1 Like

Wow, that’s really quite a while. I assume after 8 years there’s nothing getting you back to paying for 10 different streaming subs (Flix, Prime, Disney, Hulu…) haha :stuck_out_tongue:

Thanks for the offer, mate! If I get stuck, I’ll happily reach out! :slight_smile:

1 Like

That always works for me with ext4 drives. Maybe this filesystem doesn’t support permissions or has partial support.