IPMI and Ubuntu Bionic + Full disk encryption

Hi there,

Had some frustration yesterday trying to setup full disk encryption along with software raid 10 and Ubuntu bionic on a server.

After thinking about canceling, today I woke up and decided to give a new try so I closed that ticket that I opened asking for cancellation.

I must be doing something wrong. Here is the partition layout:
Disks are 1 TB each.
I partitioned 1GB on each (and each with boot flag) and made a RAID 10, used that partition type ext2 for /boot. I usually do this on Raid 1, I don’t think this is the issue… but now that I think about it ? Probably not otherwise the grub setup would have failed.

Then I created another RAID 10 with the rest of the space of each disk .
Proceeded to use that new raid partition as an encrypted device / partition.
Then I configured the encrypted partition , assigned the passphrase.
Then I selected the new encrypted space and assigned it as an LVM where I created the volume group and two partitions, one is for the swap the rest is assigned as root ( / ) .
The / partition is set as ext4 with the rest of the space.
The swap is set as swap (8GB).

Installation go smooth. Setup completed. Reboot… and here is what happens, I’m expecting the OS to ask for the passphrase or to go to a grub error. However the IPMI goes dumb and right after the bios logos when it goes to boot it lose signal, like literally it says no signal in the status bar of the IPMI console. No screenshot available on the IPMI (supermicro) dashboard. Restarted , changed boot devices, yara yara, nothing. I can access bios but can’t see what’s happening after that. I don’t think is a hardware issue, more like an incompatibility ?

Does any soul here knows what’s up with this?

Thanks a lot.

Solved it by using Debian. Same setup.
The provider replied , indicating to use nomodeset , that might have solved the issue with ubuntu.