I can't connect to my nat vps (ipv4) from my home

This is my first NAT VPS, i only used common kvm vps with dedicated ip’s, so i bought it from wishosting and installed CentOS 7.

I was trying log in to ssh from my home using the data which they provided me (public ip and a assigned ssh port) but from my home it always return “connection abort or timeout” errors on -putty-


I was about to send a ticket, then i tried connect from a hetzner cloud which i have with windows server and here works perfectly, so i installed shadowsocks, assigned a port from my range and opened it on iptables, then i tried connect from my home and doesn’t work (timeout error). But yep it works if i connect from hetzner cloud server.

I don’t have any firewall or antivirus installed and i use windows 10, also tried checking with this site if i can connect to the assigned ports and seems working http://portquiz.net:55555

public ip is from OVH France, i tried ping/tracert from my home and got answer so i don’t think there is any block between ovh and my ISP.

I use DHCP with a wifi modem/router, so i think the problem is somewhere here. but don’t know what to do.

I appreciate any help or orientation.

Have you tried using the IPv6 address instead? In general I’ve found that to be more reliable than the NAT’d IP. Any good ISP should have native IPv6.

We had this phenomenon once, could be that your ISP is blocking specific ports, especially on mobile networks. Try VPN.

you can try changing your ssh to some other port, you have 20 ports assigned. maybe that will work.

No ipv6 on my isp, i tried changing port to 55555 of a current shadowsocks server i have on a kvm vps and works.

I can’t connect to any of my assigned ports on that nat vps from my home :frowning_face: