How to migrate to Mxroute without IMAP?


I had been using Free Zoho mail and now I have set up an account at Mxroute.
Since free Zoho does not let you use IMAP/POP3, I was able to export my mail account in a zipped folder which contains files in .eml extension.
Tried to import the account in Mxroute but it supports only MBOX.
Asked this over at LET but did not get any solution to my query. Tried Thunderbird but it also requires IMAP/POP3 to set up email account of Zoho.
I have been Googling and trying but not successful since last few hours. So how do I import my mails to Mxroute? Thanks for any guidance.

I use the desktop app of Microsoft Outlook but I assume you can do this with others.
Create an account on your desktop mail app using the MXroute IMAP settings, then import the EML files to that account, then wait for it to upload all the files to MXroute on its own.

note: Theory because I never handled a free ZOHO account. I did multiple ZOHO ONE accounts and those allow IMAP/POP.

Edit: Found this link with the steps.


I think I could just drag&drop EML files onto Thunderbird … Or was it some other app?
(I wouldn’t trust newer Outlook versions for anything in IMAP.)


Finally, after reading few tutorials from Google search, I imported .eml files in Thunderbird and then exported each folder and then imported individual folder in Mxroute using Roundcube.

Now, another problem I am facing. I had created an admin email account for my domain ([email protected]) and added MX records and DKIM record in Cloudflare DNS. I was able to send/receive emails. As I am using FluentSMTP plugin on WordPress, I added SMTP host, port as received in Welcome email. In SMTP username, I added the above email ([email protected]) and the email’s password in SMTP Password field. However, I am getting this error “Credential Verification Failed. Please check your inputs”. I have tried few times selecting SSL and TLS but same error. Earlier, I was using Zoho details in the plugin and was working fine.
Attached are the DNS and SMTP plugin screenshots. Appreciate any suggestions @Jarland

The MX records are wrong.
You should set them up like this:

  1. your-domain - PRIORITY 20
  2. your-domain - PRIORITY 10

The set two CNAME:

  1. mail -
  2. webmail - (if you want to use the

Then login to the admin@ at (crossbox). Create the branding and wait a few hours for the SSL to be up and running for that domain.

Also, IMHO you should not use the admin@ for the Wordpress install, set something else like noreply@ or whatever.

1 Like

I bought Mxroute through reseller and they provided the MX records.

Please try the ones I posted above and let us know how it worked out.

1 Like

I changed the MX records and added Mail CNAME. But when I added Webmail CNAME, got this error:

An A, AAAA, or CNAME record with that host already exists.

Do I need the 2 CNAME records?

No, you need to edit or delete the one you had before.

As I don’t need to login via , so I deleted the previous CNAME and did not add the 2 CNAME records above.
However, I am still getting Failed Credentials error in the SMTP plugin. I have been reading tutorials, watching videos of Mxroute but still the error.

You need to add the CNAME:
alternatively, you can do CNAME:

Failed credentials could be the wrong CNAME, the actual credentials, or the settings.
Take a print screen of your settings on the fluentsmtp plugin.

I’ve set up that plugin numerous times to work with MXroute.


So after changing the CNAME to, now the SMTP plugin worked. Thanks for all the help.

BTW, why not admin?

1 Like

Happy to help :slight_smile:

  • Perception by who received the email. OMG the admin uses his own corporate email for automation…
  • Organization. The admin@ is used to set up crossbox
  • Misleading. The admin ain’t reaching out to people.
  • Are you replying? Are you planning to reply to a users that gets a notification and sends a reply?

But this is totally subjective.
I prefer to set up automation as follows.

  • website admin notifications. [email protected]. These go to a blackhole. I don’t need them. This reminds me I still have to update a few legacy sites that still use support@. Its a bitch.
  • Marketing automation.
    – If I plan to reply. [email protected]
    – If I don’t plan toreply. [email protected]
1 Like

I am using admin email for Wordpress alerts and notifications only. For correspondence, I use a different one. Or maybe I should change admin to [email protected] for WP alerts.

Next, I downloaded MXlogin app on Android phone. I received this in my welcome email:

Mobile client is available Android & iOS; it requires zero configuration & can be used directly, even by non-technical people.
Please download 'MXLogin ’ app from play store/app store.
Simply Login with the email ID & password you created in the control panel.

However, while logging in, got the error “Not Found”. Searched LET for solution and found a reommendation to use CrossBox app. Downloaded the app and was able to login. Then tried again in MXlogin app and was able to login there too. So is this a bug that we need Crossbox app along with MXlogin app on mobile?

I’ve never used the app.
But I know that we are to use the admin@ account and log in to The first time you do it, the app creates everything for you. And from that moment onwards, you can use crossbox without further due.

I’m guessing that when you used the crossbox app, that crossbox did the step above after you logon.

Try to uninstall the crossbox official app now, and then login using the MXroute app.


Uninstalled Crossbox and Mxlogin app is working fine now.