Hetzner Installimage Password Not Working

Anyone ever had an issue with Hetzners installimage where the root password isn’t set to the rescue system password after rebooting, and therefore you can’t login?

Can’t say I have, though I typically use SSH keys. Have you tried running through the process again?

Yeah, I’ve tried Debian 9 and 10.

It’s either an image issue, or for some reason down to the drive setup - it’s always worked fine previously. Didn’t think you set SSH keys for the rescue image?

There’s a few more combinations I’ve got to try yet but never had it before…

Interesting. Yeah, when you activate rescue mode you can set it to use one of your SSH keys.

Ah might give that a go tomorrow.

Just strange as it’s always worked the other way. I did wonder if the disk setup I was trying was confusing it for some reason but unless it’s booting from some other partition I can see why it wouldn’t work as “Setting root password” is one of the steps.

1 Like

Are all disks being formatted during the install process? If not, you could always manually format them from installimage.

Is this the server I transferred to you? If so, installimage alone will give you a bit of hassle due to the custom storage configuration. You’ll want to comment out the two hard drives during installimage, then completely delete the partition table for the hard drives before rebooting into the system. Once you’re logged in to the system itself, you can manually setup RAID (or not) and automatic mounts. Let me know if you need anything :slight_smile:

1 Like

As I’m only setting up 1 disk initially for the OS then the others aren’t formatted, so I guess in theory there could still be a partition table on them.

My plan was the setup RAID on the remaining drives once the OS was installed. The rescue system formats the partitions as setup in the config file, and on the correct drive, but as soon as I reboot I can’t login. I’m going to try with an SSH key - it makes sense as would save time anyway rather than adding one in afterwards.

I killed the data and installed a new OS (on the hard drives) before handing the server over to you. It’s booting into the hard drives, so you need to format them. That’s probably what’s causing your issue.

Just to add, ssh key doesn’t work.

Just out of curiosity what did OS did you put on after formatting?

Probably Debian 9/10 or Ubuntu 18.04, I can’t remember haha. Go into installimage and just delete the partition table from the hard drives using fdisk.

1 Like

Yeah I just noticed debug1: Remote protocol version 2.0, remote software version OpenSSH_8.0p1 Ubuntu-6build1 from ssh with -vvv flags.

I’ll retry in the morning removing the partitions from the other drives but I suspect that’s the issue. For some reason I just assumed as part of the transfer process their system removes partition table data/etc but would make sense that it doesn’t.

1 Like

Nope, the transfer process itself doesn’t do anything to the server (since you might want to transfer an as-is system between accounts). I thought that would probably be the issue — sorry about that!

Lol I wiped all partitions from the 2 HDDs and re-ran installimage just using the SSD and now it won’t come back up.

Yeah transferring “as is” makes sense, but I figured the rescue image would then reset everything - probably should have assumed it wouldn’t especially when excluding drives.

Hmmm. If you’re fine with it, boot into rescue mode and send me the password (as well as what OS you want), I’ll see if I can figure out what’s going on :slight_smile:

Only thing I can think is that the SSD isn’t set as a boot option.

I’m trying a couple of things first as I like to see if I can work it out but thanks for the offer :slight_smile: will let you know how it goes :slight_smile:

1 Like

Here’s a thread that I created when I was initially having issues, which @Falzo was able to resolve for me :stuck_out_tongue:


Brilliant, cheers.

I tried installing grub across all 3 drives but it was failing on the HDDs for some reason.

I’ll go through the thread and see if I can get it sorted.


Let me know of you need help mate. The password stuff sounds a bit weird though.


I think the password issue was the server booting from the wrong drive into the old OS.

Not sure what I’ve done now but it won’t even boot into the rescue system :rofl:

Other than that - I’ve got an OS installed, and 2 boot partitions on the HDDs - next plan is to boot into the rescue system, mount the OS partitions, chroot into it and reinstall grub across all the drives.

Sorted it!

Created small 100mb partition at the start of the HDDs, which initially failed until I changed the partition type to “BIOS Boot”. I then mounted the root filesystem and reinstalled grub onto all drives.

Thanks @Wolveix and @Falzo :slight_smile: