Help installing softaculous in myvestacp (vestacp fork)

Debian 10. GitHub - myvesta/vesta: myVESTA Control Panel with multiple PHP.

When i run

/usr/local/vesta/php/bin/php -m | grep ioncube

returns nothing


sh /usr/local/vesta/ioncube/


sh: 0: Can’t open /usr/local/vesta/ioncube/

root@xxx:~# /usr/local/vesta/bin/v-add-vesta-softaculous
dpkg-query: no packages found matching vesta-ioncube
Error: vesta-ioncube package installation failed

I used command to change php cli version
update-alternatives --set php /usr/bin/php7.3

PHP 7.3.11-1+0~20191026.48+debian10~1.gbpf71ca0 (cli) (built: Oct 26 2019 14:20:37) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.11, Copyright (c) 1998-2018 Zend Technologies
with the ionCube PHP Loader + ionCube24 v10.3.9, Copyright (c) 2002-2019, by ionCube Ltd.
with Zend OPcache v7.3.11-1+0~20191026.48+debian10~1.gbpf71ca0, Copyright (c) 1999-2018, by Zend Technologies

Can’t find info to fix this most post are only for centos… glad if someone can help me to fix this.


What’s the output of?

ls -l /usr/local/vesta/ioncube/

ls: cannot access ‘/usr/local/vesta/ioncube/’: No such file or directory

These are two of the worst ideas put together that I’ve ever seen.

Insecurities, and one click install software which is generally known to not be secure either.

I will try in next 2 days to find the time to put softaculous in myVestaCP.

1 Like

Not complete solution, I’m not sure where is the problem.

Finaly solved - How do I install softaculous on myvesta? · Issue #39 · myvesta/vesta · GitHub

1 Like

thank you so much for this update.

i tried a fresh myvesta installation with debian10 and run your softaculous script but i still get error " * The MySQL Connection could not be established."

curl -O
bash --vsftpd yes --proftpd no --iptables yes --fail2ban no

curl -O

i’m running auto installer with a user account (not admin).

i can create databases and manage them from phpmyadmin without problems.
also i’m using custom port and secret url parameter.

I have no idea.
Looks like installer didn’t get fresh version of vesta-php.

I would like to take personally look to your server if you provide me SSH access.

I will try again on my test server.

Hmmm, yes, i got the same error again.
OK, back to drawing table.
No need to send me SSH access, because I reproduced error.

Ehm, it’s because secret_url login… ok, it will be easy to solve… give me few hours.

rm /var/cache/apt/archives/vesta_0.9.8-26-3_amd64.deb
apt update && apt install --reinstall vesta