Beta Testers Needed for New VPS Service

Hello all!

I need your help! I’m asking for you to help test out a new service I’ll be offering. Test the performance, find any bugs, and report your feedback is all I ask!

What you will get:

-1GB Ram
-15 GB NVMe Storage
-1TB Bandwidth
-1 Core (Ryzen 3900X)
-1 IPv4
-Location: Chicago, IL, USA

This Package will start at ~3.50-4/month when it goes live.

As a thank you, you will have the option to renew and keep the server at a rate of $30/year! This is stackable incase you need/want a larger server!

How do I get signed up? Simply visit the link below to order the product and signup. When you add it to the cart you will be presented with an offer titled “Free Beta Trial.” Once you click “Claim Offer,” Your price should drop to zero and you can checkout. Orders will be provisioned manually and must pass a fraud check.

At the end of term, an invoice will be generated and due for the promised amount mentioned above. If you wish to not keep it you can simply cancel or let it expire.

Sign Up Here

Thanks again for your time and help!

If you have any questions, please ask!


Thanks to everyone who has signed up so far! All orders have been provisioned as of now. You should have gotten an email indicating this. I’ve already been able to smash out a few issues.

Thanks again everyone!

1 Like

Alright, some initial feedback:

  • Nice interface! (Hostbill)
  • I couldn’t reach the server’s IP somehow, not with ssh -l root or pinging. (Maybe because of below…)
  • I had selected Ubuntu on ordering, but got Debian-netinst.
  • When I tried to rebuild the server on a different image, it wasn’t entirely clear if I just had to wait longer, or if it failed (because it showed an Error status, not a Rebuilding one). Or maybe other images don’t work yet? Only when I rebuilt with Debian-netinst it indicated it was rebuilding, but I still couldn’t reach the VM. When I opened the console, it turned out I had to perform the install remotely, so it’s not an image, it’s just a mounted ISO. Which is cool, just that I’ve most often encountered a full image being imaged.
  • So I uploaded (by URL) a different ISO, and installed that, which worked well, but perhaps there should be a way to update/change the Server Details > Operating System.

And now I suddenly can no longer log in to HostBill at all… I can still access the server over ssh.
[Update: Could log in again, and the tag I set was displayed on the service selection, so that is very helpful…!]

Another thing I noticed is that all the different RAM options all say “Ram:1GB” on Place new Order - Inspire Solutions LLC
(and also on the order details pages).

Starting off: It would probably be good to require email confirmation.
Your mail server is set up pretty well, the mail arrived instantly and didn’t even run into my greylisting. Good job.

EDIT: I couldn’t add my SSH key. The UI complains that it wants it in OpenSSH format, which is what I thought I put in.

If you see the email headers. Joshua is using mxroute for email so the emails will reach you :ok_hand:


Love mxroute. Didn’t even bother to check - if it gets past my rspamd, it’s probably good :slight_smile:

1 Like

This is strange: when running a speedtest, the server location is almost 1000km away from Chicago, somewhere in Kansas…?!?

Apologies on that one. Was my fault! I ended up breaking templates right before starting this so they weren’t working. I’m currently in the process of rebuilding them. As of writing, Ubuntu 18.04 is available as a template.

If you use the “Rebuild” function and select your ISO it will change the Operating System name to whatever the iso name is.

Will look into maybe adding this!

Hmmm, that is odd. I just tried and worked fine for me. Is it possible you did the private key instead of the public? That would cause that error.

Geolocation is most likely off. I’ll work to get this corrected!

1 Like

I used the Custom ISO option, but the OS stayed on netinst.

This was using Speedtest. They go by pinging their vast network, and selecting the closest ones. In this case Wichita, KS. Networking-wise, it must be close to there, right?

[Later on…]
Now it is connecting to a server in Durand, IL (still thinking it is 889.76 km away from it…!)

My IP address (located in Mexico) is banned to access the client area. I have to use a USA VPN to access my VPS. When ordered I choose Ubuntu but I got another OS. I received an email with my login details but I got no URL of the client area in the email. I tried to access the client area at: with no luck.

I can successful login from this URL

VPS Memory is 985 MB, I was expected to get 1024MB as your offer is 1 GB RAM :slight_smile:

I made some benchmarks for reference.

Geekbench 5 Score = 1244

Your VPS 1 Core 1 GB RAM AMD Ryzen 9 3900X

Geekbench 5 Score =905

VPS 1 Core 1 GB RAM AMD EPYC 7302P

Uptime: 100% for last 6 days.


If they dont have enough info they do fall back to Maxmind. And Maxmind thinks it’s in Kansas since it’s a new range. This should be updated with Maxmind next Tuesday with the correct location. :slight_smile:

Shoot me a PM or ticket with the IP and I’ll check.

I’ve added a URL to the welcome email and info on managing the VM within the client area to avoid confusion. The first link you posted is our older Client area where our Shared Hosting customers access their details. With this New product we’ll be accepting all new orders at Inspire Solutions LLC from there on out.

Theres usually some reserved for the OS. If you run sudo dmidecode -t memory | grep -i size it should show you what’s allocated Size: 1024 MB

Also, feel free to sign up if you’re interested and reading this. The beta test will last till December 1, 2020.

Thanks for everyone who has participated so far!

1 Like

I opened a ticket for some questions, nice job :smiley:

OK, final feedback before the Beta ends, the invoice for $30 doesn’t (clearly/at all) state it’s for a year of service (neither the email, nor the pdf).
For the rest, the uptime was good, the speed was good, and the web interface for the service unequaled.

It should show a date somewhere on there for the renewal period like this >>> (12/01/2020 - 11/30/2021)

Right, it did in the item: (12/01/2020 - 11/30/2021)

1 Like