Streaming Music Servers

I know someone who’s been doing that for years, personally I’ve only been doing it for a few months.

Not sure why this didn’t trigger any responses … Anyways, trying out Plex on a VPS now. Tried mounting the music share from Koofr using rclone, but it seems rclone mount won’t work on Debian 10 (installed new rclone deb, seems man page indicates mount would need Go version 1.13, Go isn’t even installed … tried --verbose and --fuse-debug, but got nothing, I guess I’d have to strace it or something).

Anyways, mounted Koofr dir as WebDAVS. So far haven’t been able to stream anything. Might be that indexing library uses all resources available … It’s only 1 % through indexing my -12k songs … :sweat_smile:

Seems Plexamp needs a Plex Pass. Plex app needs a Plex Pass or an in-app unlock to stream more than one minute …

Plex Pass Lifetime would usually get special deals on Black Friday, I guess … A bit expensive just for streaming my own music …

Go is only needed if you’re building from source. You shouldn’t be installing via apt, you should be installing it via Install. Also, make sure fuse is installed.

Tried both the install script and apt, and fuse is installed … :thinking:

Did you try mounting with the log flag set? That would provide some more information :slight_smile: I haven’t had an issue with Rclone mounts in 4+ years, and I’ve dealt with so many different environments for it. Hence why I’m interested :smiley: What did your mount command look like?

Tried stuff like
sudo mount -t davfs -o noexec /srv/music

And options like --verbose and --debug-fuse if I recall correctly …
And --poll-interval 0 and other probably not very relevant options.

All I got was:
2020/10/12 20:29:57 INFO : koofr:f28df6f9-1af1-4fe7-b40c-c386df789e0e:music: poll-interval is not supported by this remote

Seems I did use the install script last:
The latest version of rclone rclone v1.53.1 is already installed.

That mount command looks incorrect. Did you add the remote prior to mounting? You do this via rclone config. When you create a remote, you specify its name, which you then use in commands with a colon after it. A standard mount example would be:

rclone mount remotename:/path /localpath

Haha, that was my DAV mount command … :laughing:

I used rclone mount Koofr:/music /srv/music and tried those mentioned options.

Seems rclone mount issue is Koofr specific. Could mount pCloud:
2020/10/13 14:31:29 NOTICE: pcloud root 'My Music': --vfs-cache-mode writes or full is recommended for this remote as it can't stream

Maybe mount read-only for Plex? :slight_smile:

1 Like

Seems Plex still ignores my ID tags for genre … :weary:

You don’t have to, but it is recommended. I mount my GDrive to /mnt/remote and then merge it with /mnt/local into /mnt/media using MergerFS :slight_smile: Anything can then write to tbe merged path and it’ll write to local (before being uploaded to GDrive).

Configure your library agents :slight_smile:

:thinking: Doesn’t seem very clear to me how …

I just want it to accept my IDv3 tags, instead of relying on whatever it thinks it knows from other sources …

This maybe, Prefer local metadata (editing Library):

I have to get it to rescan? (After 20 hours it’s only 25 % done …)

1 Like

Yeah, you’ll need to either refresh after the scan, or cancel and start again. Yeah, my collection took a long time initially.

Why merge, instead of just adding a second directory to the library? :nerd_face:

Because content gets uploaded to GDrive daily, so Plex would need to re-scan for the media. Merging solves various issues like this.

Maybe I’m slow, but how does MergerFS solve the need to rescan? :thinking: :sweat_smile:

Oh, and BTW rclone mount now works … Must have been a network/server issue at Koofr or something.

Plex would need to re-scan as the path to the media changes upon upload. The content goes from /mnt/local/ to /mnt/remote/. Using a merged mount on /mnt/media means that the path never changes.

Great! :smiley:

Ok, I am kinda slow … :wink: Why does the path change/the content go from /mnt/local to /mnt/remote?
When I upload some new content to my pCloud or Koofr drive, I copy it to the correct artist dirs, and it’s directly reflected in that rclone mounted volume on my VPS … (I suppose?) But I guess Plex would need to scan to discover new content … :sunglasses:

Speaking of scanning. I changed the option for metadata and restarted scan. But now it remember both the correct metadata, and the data it somehow figured out itself while scanning before I changed the options. Any easy way to have it ditch the crappy first metadata and keep the current. Or would I have to delete and re-add the music directory? :thinking: :sweat_smile:

@Wolveix has it set up so as soon as media is downloaded, it gets immediately added to his Plex server. Then at some point in time during the day/night (i.e. ideally during times the box is idle or near-idle), his content gets uploaded from his local storage to GDrive, then subsequently deleted from local. During this changeover, the content itself never leaves the merged mount, so Plex always has access to it.

Having it set up like he has it just makes it so the content is immediately available for consumption before the GDrive upload occurs. You don’t need to do it this way if you’re fine with a slight delay with content being added to your Plex server (i.e. after it syncs to GDrive). I just have my Plex mount set to the /mnt/remote equivalent on my machine since I’m fine with a slight delay (several hours to a day) between my server downloading the content and it finally being added to the Plex server (when the upload cron is ran).

Hope that makes sense.

1 Like

Perfect, thanks! :smiley:

(Still looking for an easy/quick way to have it do metadata cleanup – ignore the crap it assumed from other sources, and trust my tags.) :wink:

Thanks for clearing that up @Mason :slight_smile:

@flips you should be able to just “Refresh Metadata” for the whole library.