Configure Multiple External IPs Within Proxmox

Hey guys. Thank you very much for your time.

I’m going to test the config you posted in a couple of hours.

Maybe a mod (@Wolveix) can move these posts to a new thread?


Let me know how it goes :slight_smile:

@imok I’ll probably be drunk as hell back at around midnight (cet). somehow I am very certain that I am fully capable to mess up your box completely by then :stuck_out_tongue:

Isn’t that the best time to configure networking?

1 Like

Are we still fighting with proxmox sir?

Always. But this battle has been paused until I complete my hours at work.

ready to fuck up everything that’s left get it going now?

1 Like


@imok sorry you missed your time slot. falling asleep right now.



You can drink and fix Promox issues tomorrow too.

Meanwhile me and the entire world:

Are you sure the door is closing properly? :joy:

@Mr_Tom tested your config and it worked! Thank you very much! I went with your way first because it requires less interfaces.

Thanks @Falzo for your time, too.

@seriesn you should add virtual macs to the control panel in the future, it will be a lot easier :sweat_smile:

Internal network was not working because the interface in the guest was down :joy:

1 Like

Glad it’s all up and running!

1 Like

Something to add it to my to do list. That list is getting longer.

Did you add “taking over the world” to the list?

1 Like

Hm, @SERIESN for president? :thinking::sunglasses:

1 Like

Herr Flipz as PM ?

Totally! President of my own basement country, works perfectly well. No leak, no deficiency.

1 Like

Sounds stressful :wink:
(Wonder if we might have derailed this thread, BTW) :crazy_face:

Problem has been solved, so it does not matter.

1 Like

Host was powered off until I start a real use.

I was going to start migrating files but /etc/network/interfaces has changed to:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static

auto eth0:0
iface eth0:0 inet static

auto eth0:1
iface eth0:1 inet static


Automatically, I don’t know why.

And VMs won’t start because vmbr0 does not exist anymore.

Why would this happen? I’m 100% sure I didn’t do this.